#1 2023-03-17 20:24

Registered: 2023-03-17
Posts: 2

Network interface can't be selected correctly

Hi there,

I've tried to monitor the internet traffic to decide when to shutdown, but no appropriate interface could be set.
The one with red color underline is the right one and could be saved.However, no stream could be detected in status and when i back to the
configuration it is already overrided by another interface. All the versions including portable and beta had been tested and the same issue still came out.

This issue is also found in another similar app, but I also found one could work normally with this interface means it's the correct choice.
Is there any solution? My OS is win10.


Last edited by kenny2963 (2023-03-17 20:31)


#2 2023-03-19 10:10

From: den4b.com
Registered: 2006-04-06
Posts: 3,400

Re: Network interface can't be selected correctly

Perhaps your network interface has a dynamic (changing) MAC address?

Shutter stores the selected network interface by its MAC address, so if it changes Shutter won't find the right interface.

You can save your Shutter's configuration in a dummy preset, then open the preset file with a Notepad and locate the MAC address that Shutter has saved. You should see something like that:


Check against the list of available MAC addresses on your system, see https://www.digitalcitizen.life/4-ways- … indows-81/


#3 2023-03-19 14:34

Registered: 2023-03-17
Posts: 2

Re: Network interface can't be selected correctly

That's weird.
My Mac address is not dynamic and is saved correctly in the prest file.
but the status is still 0 KB/s all the time even opened with admin.

It seems that shutter knows the exact mac but is failed to acquired it.
The following picture shows the overidded option after I saved the correct one with ip in the beginning.
Is it relevant that i'm using Wifi for internet?



#4 2023-11-16 19:58

Registered: 2023-11-16
Posts: 1

Re: Network interface can't be selected correctly

I have a similar problem.
My selected network card is not saved correctly.
MAC address is static and yet it always jumps back to a default adapter after saving.

What I specify:

What ShutterPro saves:

But everything looks correct in a saved preset.
No traffic is displayed either.
So it doesn't seem to be just a display problem

Every other adapter is saved correctly.
Any suggestions for solutions?

Okay, took another adapter as main adapter.
Problem solved for me!

Last edited by Xris (2023-11-17 01:25)


Board footer

Powered by FluxBB