#1 2019-07-19 17:21

G2DHT89RIDLW
Member
Registered: 2016-12-11
Posts: 12

RandPass "Use Custom Characters" Bug?

Hi.

I found a bug in 2.0.0.1 beta (although it may exist in a previous version also)...

The checkbox option Use custom characters is not honnoured.
When RandPass is started, it is ALWAYS checked (ticked).
If you uncheck it, restart RandPass it is checked.

The value in Settings.ini is always set "UseCustomChars=1".
Manually set the value to "UseCustomChars=0", then File>Save.
Start RandPass and Use custom characters is checked.
The settings.ini value has reverted back to "UseCustomChars=1".

Last edited by G2DHT89RIDLW (2019-07-19 17:26)

Offline

#2 2019-07-20 09:43

den4b
Administrator
From: den4b.com
Registered: 2006-04-06
Posts: 2,856

Re: RandPass "Use Custom Characters" Bug?

Thanks for reporting this issue!

It is caused by an inconsistent callback in the component which is meant to detect a change of text.

It will be addressed in the next version.

In the meantime, please clear the custom characters field to disable it.

Offline

#3 2019-07-20 09:55

G2DHT89RIDLW
Member
Registered: 2016-12-11
Posts: 12

Re: RandPass "Use Custom Characters" Bug?

den4b wrote:

It will be addressed in the next version.

Thanks. I shall look out for a new release soon.
PS I discovered deleting the custom characters "fixed it", but I occasionally use/need them so the easiest option in the meantime for me is to uncheck before generating.

Offline

#4 2019-07-23 21:48

den4b
Administrator
From: den4b.com
Registered: 2006-04-06
Posts: 2,856

Offline

#5 2019-07-24 05:48

G2DHT89RIDLW
Member
Registered: 2016-12-11
Posts: 12

Re: RandPass "Use Custom Characters" Bug?

den4b wrote:

This issue has been fixed in RandPass 2.0.0.2 Beta

Thank you for the quick fix.

Offline

Board footer

Powered by FluxBB