#1 2020-08-20 01:33

Registered: 2020-07-03
Posts: 7

"User-mode process attempted to change the system state..."

Intel NUC8
Win10 Pro 1909
Shutter Lite 4.4

Windows decided to install the May 2020 feature update (v2004) all by itself which caused serious problems with my Plex suddenly not being able to write to my network drives, so I reverted to Windows 10 v1909 and disabled Windows Update.

Ever since reverting, I've noticed my system has trouble going to sleep.  Looking at Shutter, I see it is running, but it is restarting about every 15 minutes (in line with my events).  However, my system is not going to sleep.

Looking at my system logs, I see about every 15 minutes this Kernel Power error
"User-mode process attempted to change the system state by calling SetSuspendState or SetSystemPowerState APIs." for Shutter.  So basically, Shutter is telling the system to go to sleep and the system is ignoring it.  I have the full XML of the message if that would help.

I tried reinstalling Shutter, making sure I ran it as administrator, but it didn't make a difference.

Restarting my system does something, and Shutter will work for several hours, but within a day or so, it is back to failing to sleep with this error.

Anyone have any ideas?

I'm incredibly disappointed with Microsoft - shipped a broken update, forced the update on me, and has a broken rollback mechanism since my system is now somehow different since Shutter is failing.  I'm about ready to give up on Plex - I don't have time to handhold a server.

Screenshot of the repeating kernel power errors in the system log
kernel power errors from shutter

Last edited by solstyce9 (2020-08-20 01:33)


#2 2020-08-20 09:27

From: den4b.com
Registered: 2006-04-06
Posts: 3,202

Re: "User-mode process attempted to change the system state..."

I completely agree with your assessment on Windows/Microsoft. They continue to break backward compatibility and user preferences. However, it will take quite a bit more than a few broken parts to get everyone to switch away from the Windows platform. So we'll just have to continue finding ways and workarounds for un-breaking it.

One of the common causes of a failed shutdown request is some application preventing the shutdown procedure, by reporting that it is not ready to shutdown. You can try using the "Force" shutdown option, or try finding out which application prevents the shutdown by eliminating all non-essential applications, e.g. terminating them manually one by one until you find the offender.

Alternatively to using the Shutdown action in Shutter, you can try to initiate the shutdown via the Microsoft's "shutdown" tool. Perhaps it will have more luck.

An example usage of the shutdown command:

shutdown /s /t 0 /f

The shutdown command reference:
https://docs.microsoft.com/en-us/window … s/shutdown


#3 2020-08-21 16:04

Registered: 2020-07-03
Posts: 7

Re: "User-mode process attempted to change the system state..."

Gave the force option a try but looks like I'm still having the problem.  I found a few threads on the Microsoft support site that have tips on troubleshooters and resetting system defaults.  So I'll try those and hopefully can eventually get my system back to waking on network traffic and sleeping at Shutter's request.


Board footer

Powered by FluxBB