#11 2024-02-27 17:30

den4b
Administrator
From: den4b.com
Registered: 2006-04-06
Posts: 3,388

Re: Error "Unable to initialize Open SSL library"

These issues appear to be caused by having several different versions of OpenSSL library available on a given system.

In Shutter 4.7.0.1 Beta, we have changed the OpenSSL library version precedence to load newer versions first, as summarised below.

      1                   2                3              4
--------------    -----------------   ------------   ------------
libssl-3.dll      libssl-1_1.dll      ssleay32.dll   libssl32.dll
libcrypto-3.dll   libcrypto-1_1.dll   libeay32.dll   libeay32.dll

This should avoid accidental use of outdated libraries found somewhere else on the system.

Dynamic-link library search order explains how the operating system finds a requested library.

Offline

Board footer

Powered by FluxBB